Вход на сайт
Регистрация
Вход для зарегистрированных:
Войти
Закрыть
Восстановление пароля
Регистрация
Отправить
Восстановление пароля
Ведите учет и сдавайте отчетность. Веб-сервис для предпринимателей
С 1 февраля розница должна перейти на онлайн-кассы Подключиться к сервису для работы с онлайн-кассами

Создание формулы в Excel

Julia_89 (автор вопроса)  508 баллов, г. Красноярск
28 ноября 2014 в 09:56
День добрый!
Вопрос к профессионалам программы Excel. 
У меня excel 2007.
Может кто знает как сделать правильную формулу?
есть 2 ячейки. В первой сотрудник будет писать (текст!) либо "да", либо "нет", либо ячейка останется пустой.
Во второй ячейке нужна формула: если в первой ячейке будет написано "да", то во второй должно проставиться число "1", а если "нет", либо пусто, то "0" (ноль).
Я с экселем очень даже дружу, но не понимаю как можно сделать такую на вид простую формулу. Загвоздка именно в тексте.
Ефимов Павел  84 604 балла, г. Ивантеевка-2
28 ноября 2014 в 10:01
Здравствуйте.
Логический 0 вернётся если пустой и 1 если не пустой.
В Excel:
=ЕСЛИ(A1<>0;1;0)
Julia_89 (автор вопроса)  508 баллов, г. Красноярск
28 ноября 2014 в 10:04
Цитата (Ефимов Павел):Здравствуйте.
Логический 0 вернётся если пустой и 1 если не пустой.
В Excel:
=ЕСЛИ(A1<>0;1;0)
Спасибо, Вы меня очень выручили! Цветы
Придется обойтись без слова "нет". Либо "да", либо пусто.
ПомБух  60 014 баллов, г. Челябинск
1 декабря 2014 в 10:57
Здравствуйте.
Цитата:Julia_89
Придется обойтись без слова "нет". Либо "да", либо пусто.
Ну почему же?
Функция:
=ЕСЛИ(А1="Да";1;0)
вернёт логическую единицу, если в ячейке А1 написать Да (причём регистр - не важен). Во всех остальных случаях (в том числе и при "пустой" А1) вернётся ноль.
Julia_89 (автор вопроса)  508 баллов, г. Красноярск
1 декабря 2014 в 11:15
Точно! Спасибо за ликбез! Свист
Сейчас смотрят
Смотрят тему:
гость
   
Ответить Задать вопрос

Закладка перемещена в  Отменить перемещение

закрыть
Для корректного отображения сайта установите новую версию браузера Обновить браузер