Вход на сайт
Регистрация
Вход для зарегистрированных:
Войти
Закрыть
Восстановление пароля
Регистрация
Отправить
Восстановление пароля
Ведите учет и сдавайте отчетность. Веб-сервис для предпринимателей
С 1 февраля розница должна перейти на онлайн-кассы Подключиться к сервису для работы с онлайн-кассами

В книгу покупок не попадают данные об уплате налога (НДС по Белоруссии)

1 июля 2015 в 09:52
Здравствуйте.
Собственно вопрос.
Отражаем НДС по методу https://www.buhonline.ru/forum/index?g=posts&t=69344
А по какой то причине данные о платежке (номер и дата) не попадают в колонку (7) КнигиПокупок.
Получается только, когда бухгалтер введет "Корректировку движений регистров" на документ "ОтражениеНДСкВычету" и из двух строчек регистра одну строчку (верхнюю) сторнирует, а в другую (вторую строчку) - введет номер ПП и дату ПП, а также сумму из верхней строчки.
После этого действия при формировании КнигиПокупок данные о платеже отражаются.
Что делать, подскажите пожалуйста.
Ирина Ротнова Модератор
1 июля 2015 в 10:04
Добрый день. Поскольку речь идёт о работе в программе, переношу в соответствующий раздел ("Тонкости работы в 1С, Контур-Зарплате, ..."). Будьте, пожалуйста, внимательнее при выборе раздела для размещения вопроса.

 Укажите, пожалуйста, название программы, а также релиз конфигурации. Без этой информации Вы рискуете получить неполный или даже неверный ответ. Для уточнения информации обязательно воспользуйтесь этими рекомендациями. А найти справку о названии и релизе конфигурации в своей программе вам поможет это наглядное пособие.
1 июля 2015 в 10:12
У нас база:
1С:Предприятие 8.2 (8.2.19.121)
Управление производственным предприятием, редакция 1.3 (1.3.62.2)
Подарок для новых ИП!
Ведите учет и сдавайте отчетность бесплатно
Расчет зарплаты
Удобно с сервисом Контур.Бухгалтерия
С 1 февраля розница должна перейти на онлайн-кассы
Подключиться к сервису для работы с онлайн-кассами
2 июля 2015 в 08:02
Цитата (Мааария):Что делать, подскажите пожалуйста.
Похоже придется дописывать 1с, либо книгу покупок, либо проводки по НДСпокупки документа ОтражениеНДСкВычету...?
Алена Светлая Консультант
4 июля 2015 в 15:08
Здравствуйте!
Цитата (Мааария):Отражаем НДС по методу Учет белорусского НДС в 1С: Предприятие 8.2
А по какой то причине данные о платежке (номер и дата) не попадают в колонку (7) КнигиПокупок.
Получается только, когда бухгалтер введет "Корректировку движений регистров" на документ "ОтражениеНДСкВычету" и из двух строчек регистра одну строчку (верхнюю) сторнирует, а в другую (вторую строчку) - введет номер ПП и дату ПП, а также сумму из верхней строчки.
После этого действия при формировании КнигиПокупок данные о платеже отражаются.
Что делать, подскажите пожалуйста.
В УПП в настоящее время включаются изменения и дополнения, в том числе, касающиеся учета НДС и формирования отчетности по НДС, Весьма желательно следить за актуальностью релизов и своевременно обновлять конфигурацию.

Дописать конфигурацию, наверное, можно. В особенности, если она у вас уже "дописанная".
Однако, если проблема только в дате платежа и номере платежки, то лучше применить стандартный документ "Формирование записей книги покупок", который предназначен для регистрации вычетов сумм НДС. Обычно он заполняется в автоматическом режиме. Но т.к. в редакциях конфигураций на платформе 8 типа КА 1.1, УПП 1.3., БП 2.0 (Бух.) и т.п. не автоматизирован импорт из Беларуси или иных участников ЕАЭС (сообщества "Евразийский экономический союз") , то выбрать дополнительный ввод отдельного док-та "Формирование записей книги покупок", заполнить его "вручную", не настолько уж затруднительно.., если, конечно, вы не импортируете товары из Беларуси постоянно. Тсс!

Напомню, что в док-те "Формирование записей книги покупок"  есть графы и для номера платежки, и для даты уплаты. А после проведения всех необходимых регламентных операций и обработок при закрытии периода, у вас должны сформироваться все нужные записи в Книгу покупок, включая даты оплаты НДС в бюджет по сделке с белорусским партнером.
6 июля 2015 в 08:32
Алена, спасибо за развернутый ответ. Да, нам не удобно заполнять вручную документ ФормированиеКнигиПокупок. Поэтому я дописала документ ОтражениеНДСкВычету. Комментарии принимаются - может что то не учла вдруг. Только вопрос в том, что делать если будет несколько Платежек?
В моем решении я беру только первую из них.

В модуле объекта:

Процедура ПодготовитьТаблицыДокумента(СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоДокументамОплаты) Экспорт
       СтруктураПолей = Новый Структура();
СтруктураПолей.Вставить("Номенклатура", "Номенклатура");
СтруктураПолей.Вставить("ВидЦенности", "ВидЦенности");
СтруктураПолей.Вставить("Сумма", "Сумма");
СтруктураПолей.Вставить("СтавкаНДС"   , "СтавкаНДС");
СтруктураПолей.Вставить("НДС"         , "СуммаНДС");
СтруктураПолей.Вставить("СчетЗатрат"  , "СчетЗатрат");
СтруктураПолей.Вставить("СчетУчетаНДС", "СчетУчетаНДС");
СтруктураПолей.Вставить("Субконто1"   , "Субконто1");
СтруктураПолей.Вставить("Субконто2"   , "Субконто2");
СтруктураПолей.Вставить("Субконто3"   , "Субконто3");
СтруктураПолей.Вставить("Событие"   , "Событие");

РезультатЗапросаПоТоварам = УправлениеЗапасами.СформироватьЗапросПоТабличнойЧасти(ЭтотОбъект, "ТоварыИУслуги", СтруктураПолей);
// Подготовим таблицу товаров для проведения.
ТаблицаПоТоварам = ПодготовитьТаблицуТоваров(РезультатЗапросаПоТоварам, СтруктураШапкиДокумента);

Если Не СтруктураШапкиДокумента.ПрямаяЗаписьВКнигу Тогда
БухгалтерскийУчетРасчетовСКонтрагентами.ПодготовкаТаблицыЗначенийДляЦелейПриобретенияИРеализации(ТаблицаПоТоварам,    
                                                                                                                      СтруктураШапкиДокумента, Ложь, мВалютаРегламентированногоУчета);
КонецЕсли;
      ТаблицаПоДокументамОплаты = Неопределено;
Если СтруктураШапкиДокумента.ПрямаяЗаписьВКнигу Тогда
СтруктураПолей.Очистить();
СтруктураПолей.Вставить("ДокументОплаты", "ДокументОплаты");
СтруктураПолей.Вставить("ДатаОплаты", "ДатаОплаты");
РезультатЗапросаПоДокументамОплаты = УправлениеЗапасами.СформироватьЗапросПоТабличнойЧасти(ЭтотОбъект, "ДокументыОплаты",
                                                                                                                                                                                                                                СтруктураПолей);
ТаблицаПоДокументамОплаты = ПодготовитьТаблицуДокументовОплаты(РезультатЗапросаПоДокументамОплаты, СтруктураШапкиДокумента);
КонецЕсли;

//+++030715++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
//При импорте из стран ТС не заполнялся документ оплаты в КнигеПокупок/////////////////////////////////////////////
СтраныТС = Новый СписокЗначений;
СтраныТС.Добавить("БЕЛАРУСЬ");
СтраныТС.Добавить("КАЗАХСТАН");

Если (НЕ ТаблицаПоДокументамОплаты.Количество()=0) и (НЕ СтраныТС.НайтиПоЗначению(Контрагент.Регион.Наименование)=Неопределено) Тогда 
ТаблицаПоТоварам.Колонки.Добавить("НомерДокументаОплаты");                                          
ТаблицаПоТоварам.Колонки.Добавить("ДатаДокументаОплаты"); 
ТаблицаПоТоварам.ЗаполнитьЗначения(ТаблицаПоДокументамОплаты.Получить(0).ДокументОплаты.Номер,"НомерДокументаОплаты");                                              ТаблицаПоТоварам.ЗаполнитьЗначения(ТаблицаПоДокументамОплаты.Получить(0).ДатаОплаты,"ДатаДокументаОплаты");   
КонецЕсли;                                                                                 
//----030715--------------------------------------------------------------------------------------------------------------------------------
КонецПроцедуры
6 июля 2015 в 08:34
Цитата (Алена Светлая):В УПП в настоящее время включаются изменения и дополнения, в том числе, касающиеся учета НДС и формирования отчетности по НДС
А вот что ответили на ЛинииКонсультации 1с:
Учет НДС при ввозе товаров из государств Таможенного союза в конфигурации в УПП 1.3 не поддерживается
и в этой редакции развития в этом направлении не планируется.
В случае, если такие операции встречаются систематически, имеет смысл доработать конфигурацию.
Сейчас смотрят
Смотрят тему:
гость
   
Ответить Задать вопрос

Закладка перемещена в  Отменить перемещение

закрыть
Для корректного отображения сайта установите новую версию браузера Обновить браузер